首页 » Miscellaneous » 正文

CCNA课堂精简笔记

网络的三层架构:
1.接入层: 提供网络接入点,相应的设备端口相对密集. 主要设备:交换机,集线器.
2.汇聚层: 接入层的汇聚点,能够提供路由决策.实现安全过滤,流量控制.远程接入. 主要设备:路由器.
3.核心层: 提供更快的传输速度, 不会对数据包做任何的操作
=================================================================
OSI七层网络模型:       Protocol data unit
1.物理层: 速率,电压,针脚接口类型    Bit
2.数据链路层: 数据检错,物理地址MAC   Frame
3.网络层: 路由(路径选择),逻辑的地址(IP)   Packet
4.传输层: 可靠与不可靠传输服务, 重传机制.   Segment
5.会话层: 区分不同的应用程序的数据.操作系统工作在这一层 DATA
6.表示层: 实现数据编码, 加密.    DATA
7.应用层: 用户接口     DATA
Bit, Frame, Packet, Segment 都统一称为: PDU(Protocol Data Unit)
=================================================================
物理层:
1.介质类型: 双绞线, 同轴电缆, 光纤
2.连接器类型: BNC接口, AUI接口, RJ45接口, SC/ST接口
3.双绞线传输距离是100米.
4.HUB集线器: 一个广播域,一个冲突域.泛洪转发. 共享带宽.
直通线: 主机与交换机或HUB连接
交叉线: 交换机与交换机,交换机与HUB连接
全反线(Rollback): 用于对CISCO的网络设备进行管理用.
=================================================================
数据链路层:
1. 交换机与网桥    2. 交换机与网桥有多少个段(端口)就有多少的冲突域.
3. 交换机与网桥所有的段(端口)在相同的广播域
=================================================================
网络层:
1. 路由器2. 路由实现路径的选择(路由决策).Routing Table 3. 广域网接入. 4. 路由器广播域的划分(隔断).
=================================================================
传输层:
1.TCP(传输控制协议),面向连接,拥有重传机制,可靠传输
2.UDP(用户报文协议),无连接,无重传机制,不可靠传输
3.端口号:提供给会话层去区分不用应用程序的数据.标识服务.
=================================================================
show hosts    显示当前的主机名配置
show sessions    显示当前的外出TELNET会话
clear line XXX    清除线路
<ctrl>+<z>    直接返回到特权模式
<ctrl>+<shift>+<6> + x
=================================================================
enable     进入特权模式
disable     从特权模式返回到用户模式
configure terminal   进入到全局配置模式
interface ethernet 0/1   进入到slot 0的编号为1的以太网口
exit     返回上层模式
end     直接返回到特权模式
=================================================================
1.当CISCO CATALYST系列交换机,在初始化时,没有发现”用户配置”文件时,会自动载入Default Settings(默认配置)文件,进行交换机初始化.以确保交换机正常工作.2.CISCO Router在初始化时,没有发现”用户配置”文件时,系统会自动进入到”初始化配置模式”(系统配置对话模式,SETUP模式, STEP BY STEP CONFIG模式, 待机模式),不能正常工作!
=================================================================
1.CONSOLE PORT(管理控制台接口): 距离上限制,独占的方式.
2.AUX port(辅助管理接口): 可以挂接MODEM实现远程管理,独占的方式.
3.Telnet:多人远程管理(决定于性能, VTY线路数量).不安全.
=================================================================
立即执行,立即生效
=================================================================
hostname    配置主机本地标识
r6(config)#interface ethernet 0
r6(config-if)#ip address 1.1.1.1 255.255.255.0
show version   观察IOS版本 设备工作时间 相关接口列表
show running-config 查看当前生效的配置 此配置文件存储在RAM
show interface ethernet 0/1 查看以太网接口的状态 工作状态等等等…
=================================================================
reload     重新加载Router(重启)
setup     手工进入setup配置模式
show history    查看历史命令(最近刚用过的命令)
terminal history size <0-256> 设置命令缓冲区大小 0 : 代表不缓存
copy running-config startup-config 保存当前配置
概念:
nvram : 非易失性内存,断电信息不会丢失 <– 用户配置      <– startup-config
ram   : 随机存储器,断电信息全部丢失    <– 当前生效配置 <– running-config
startup-config 在每次路由器或是交换机启动时候,会主动加载
=================================================================
banner motd [char c]   同时要以[char c]另起一行结束
description    描述接口注释
( <ctrl>+<shift>+<6> ) + x
为console口配置密码:
line conosle 0    进入到consolo 0
password cisco    设置一个密码为”cisco”
login     设置login时使用密码
enable password <string> 设置明文的enable密码
enable secret <string>   设置暗文的enable密码(优先于明文被使用)
service password-encryption 加密系统所有明文密码(较弱)
设置vtp线路密码(Telnet)
line vty 0 ?
password cisco
login
=================================================================
配置虚拟回环接口(回环接口默认为UP状态)
inerface loopback ?   创建一个回环接口
ip address 1.1.1.1 255.0.0.0 配置接口的IP地址
end     退出该接口
ping 1.1.1.1    检测该接口有效性
no *     做配置的反向操作
DCE/DTE 仅存在广域网中
show controllers serial 0 用于查看DCE与DTE的属性
DCE的Router需要配置时钟频率
clock rate ?    配置DCE接口的时钟频率(系统指定频率)
=================================================================
Serial1 is administratively down, Line protocol is down
没有使用no shutdown命令激活端口
Serial1 is down, Line protocol is down
1.对方没有no shutdown激活端口
2.线路损坏,接口没有任何连接线缆
Serial1 is up, line protocol is down
1.对方没有配置相同的二层协议 serial接口default encapsulation: HDLC
2.可能没有配置时钟频率
Serial1 is up, line protocol is up
接口工作正常
=================================================================
show cdp neighbors   查看CDP的邻居(不含IP)
show cdp neighbors detail 查看CDP的邻居(包含三层的IP地址)
show cdp entry *   查看CDP的邻居(包含三层的IP地址)
r1(config)#no cdp run   在全局配置模式关闭CDP协议(影响所有的接口)
r1(config-if)#no cdp enable 在接口下关闭CDP协议(仅仅影响指定的接口)
clear cdp table    清除CDP邻居表
show cdp interface serial 1 查看接口的CDP信息
=================================================================
Sending CDP packets every 60 seconds(每60秒发送cdp数据包)
HoldTime 180 seconds(每个CDP的信息会保存180秒)
=================================================================
ip host <name> <ip>   设置静态的主机名映射
=================================================================
ciscolab.njut.edu.cn
=================================================================
Telnet *.*.*.* 被telnet的设备,需要设置line vty的密码,如果需要进入特权模式需要配置enable密码
show users 查看 “谁” 登录到本地
show sessions 查看 “我” telnet外出的会话
clear line * 强制中断 “telnet到本地” 的会话
disconnect * 强制中断 “telnet外出”   的会话
=================================================================
show flash:    查看flash中的IOS文件
copy running-config tftp: 将running-config复制到tftp服务上
copy tftp: running-config
copy startup-config tftp:
copy tftp: startup-config
copy flash: tftp:
copy tftp: flash:
copy flash: tftp://1.1.1.1/c2500-ik8os-l.122-31.bin
=================================================================
ROM : Rom monitor 比Mini IOS还要低级os系统,类似于BIOS Mini IOS(2500 serial Router) 也称为boot模式,可以用于IOS的升级
nvRam : Startup-config 启动配置文件,或称为用户配置文件
Configuration register 启动配置键值, 修改它会影响Router 的启动顺序
show version   查看router的configuration register
0x0 指出router要进入Rom monitor模式
0x1 Router将会去加载mini ios软件,进入BOOT模式
0x2 Router会加载Flash中的IOS软件.(Default config regcode)
0x2142 绕过 加载startup-config 的过程, 或是:不加载启动配置,直接进入setup mode
0x2102 router默认配置键值, 执行正常的启动顺序.
config-register 0x2142   修改启动配置键值
=================================================================
交换机 function:
1.地址学习 Address learing 2.转发/过滤决策 Forward/Filter Decision 3.环路避免 Loop avoidance
=================================================================
交换机的三种转发模式:
1.直通转发: 速度快,但不能确保转发的帧的正确性.
2.存贮转发: 速度慢,确保被转发的帧的正确性.
3.自由碎片转发(cisco私有技术): 介于直通转发与存贮转发性能之间.
存贮转发,会重新计算帧的FCS与帧的原始FCS进行比较,以决定转发还是丢弃.
自由碎片转发,仅检测帧的前64字节,判断帧的完整性.
自由碎片转发机制, 仅能够在CISCO的设备上实现.
CISCO 1900 系列的交换机默认采用自由碎片转发此转发方式
======================================================================
交换机的地址学习、转发过滤等:
1.交换机会先缓存帧源地址
2.当目标地址未知时,交换机会泛洪该数据帧(目标地址已知时, 帧不会被泛洪)
3.对于广播帧与多播数据帧,交换机默认采用泛洪的方式进行转发
4.如数据帧的源地址与目标地址均来自相同的端口,交换机默认会丢弃该数据帧.
======================================================================
show ip route   查看当前路由表
配置静态路由:
ip route (Destnation Network IP) (NetMask) [NextHopIP | LocalInterface]
Destnation Network IP: 目标网络IP
NetMask: 目标网络子网掩码
NextHopIP: 下一跳IP
LocalInterface: 本地接口
1.0.0.0 2.0.0.0    3.0.0.0      4.0.0.0
—– s1 RA s0 >——– s1 RB s0 ——— s1 RC s0 ——
1     1            2     1            2     1
RA:
ip route 4.0.0.0 255.0.0.0 2.0.0.2
ip route 4.0.0.0 255.0.0.0 s0
==================================================================
自治系统:
IGPs : 内部网关路由协议, 在一个自治系统内部去维护路由
RIPv1, RIPv2, IGRP, EIGRP, OSPF, ISIS
EGPs : 外部网关路由协议, 在维护自治系统间路由
BGP
==================================================================
管理距离:决定何种路由协议生成的路由会被路由器采纳.管理距离越低越容易被路由器采纳.
==================================================================
选择路由的度量:
RIP: 是跳数做为选择最佳路由的度量值 会错误选择次佳的路由
IGRP: 根据带宽、延迟、可靠度、负载、MTU(最大传输单元)
==================================================================
距离矢量型路由协议:
1.通告的内容: 路由表的副本(copy)   2.通告的时间: 周期性   3.通告的对象: 直接连接的邻居路由器
4.通告的方式: 广播(RIPv1,IGRP)
规则机制:
1.定义最大数 2.水平分隔 3.路由毒化,毒性逆转 4.沉默计时器 5.触发更新
==================================================================
rip : Router information protocol
Rip V1 采用广播通告 广播地址: 255.255.255.255
1.以跳数作为度量 2.最多支持6条路径的均分负载(default set to 4) 3.周期性通告时间: 30s
Router rip   选择rip作为路由协议
network *.*.*.*   宣告接口
宣告接口:
1. 将此接口加入到rip进程中   2. 向其它的路由器通告此接口的网络
show ip protocols 查看RIP的相关信息
rip的管理距离:120
debug ip rip 调试RIP路由
clear ip route * 清除route表
==================================================================
Rip Version 2 :
ripv2使用是多播方式去通告网络, 多播地址:224.0.0.9
router rip
version 2 配置rip版本为version 2
no auto-summary 关闭掉自动的汇总
Ripv2 的认证 :
A(config)#key chain A     配置钥匙链 A
A(config-keychain)#key 1    配置钥匙 1
A(config-keychain-key)#key-string cisco   定义密码
A(config-keychain-key)#exit
A(config-keychain)#exit
A(config)#inte s 1     进入s 1的接口
A(config-if)#ip rip authentication key-chain A 选择A的钥匙链
A(config-if)#ip rip authentication mode md5 密文认证
=================================================================
RIP 补充:
passive-interface <inte number>   配置相应的接口不发送任何通告
neighbor <ip>     指出具体的邻居
如果neighbor和passive-interface同时配置,那么neighbor会不受passive-interface限制.
=================================================================
IGRP是CISCO私有路由选择协议,仅能够在CISCO的路由器上去实现和部署.
IGRP是使用复合型的度量值去选择最佳的路由.
1.带宽2.延迟3.可靠性4.负载5.MTU
IGRP 支持等价均分负载,同时也支持不等价的均分负载.
IGRP 在配置的时候,需要注意自治系统号.
在相同的自治系统中的路由器才能够相互的学习通告相关的路由.
IGRP 属于距离矢量型路由协议, 会做自动的路由汇总.而且没有办法关闭此特性.
IGRP 使用得是24bit度量值.
=================================================================
IGRP 配置
router igrp <as number>   as number为自治系统编号(自主域)
network <primary ip network> 主类网络号A B C的编号
debug ip igrp events   调试igrp的相关事件
debug ip igrp transactions 调试igrp的事件内容
=================================================================
链路状态型路由协议:
1.通告的内容: 增量更新(OSPF lsa) 2.通告的时间: 触发式 3.通告的对象: 具有邻居关系路由器
4.通告的方式: 单播&多播
=================================================================
EIGRP
度量值是32位长,K值不相等,不能创建邻居关系,AS自治系统不同,也不能创建邻居关系,在高于T1的速率上,会每隔5s发送hello packet,在低于T1的速率上,会每隔60s发送hello packet。
EIGRP 外部路由的管理距离: 170 EIGRP 内部路由的管理距离: 90
show ip eigrp neighbors 查看EIGRP的邻居
show ip eigrp topology 查看EIGRP的拓扑结构数据库(表)
show ip route eigrp   查看所有的EIGRP的最佳路由(存贮在路由表中)
EIGRP 采用通配符掩码配置示例:
router eigrp 100
network 192.168.1.0 0.0.0.3
network 192.168.1.4 0.0.0.3
debug ip eigrp neighbor 调试邻居创建过程
debug ip eigrp notifications 调试事件通告
=================================================================
OSPF 开放式协议,也是链路状态型路由协议.
OSPF 使用IP数据包进行路由通告和学习, Protocol Number : 89
OSPF 仅支持IP网络环境, 仅支持等价的负载均衡
=================================================================
Link State Routing Protocols
需要创建邻居关系 采用多播去进行路由通告(可靠) 拥有链路状态数据库(网络地图) 采用相应算法,比如(SPF)去计算最佳的路由触发更新
=================================================================
OSPF的结构:
1.邻居表 => 所有的邻居
2.拓扑表 => 网络的地图
3.路由表 => 最佳的路由
================================================================
OSPF创建邻居的过程:
1.Down
2.Init
3.Two-Way
4.ExStart
5.ExChange
6.Loading
7.Full
=================================================================
OSPF 层次结构优点:
1.减少路由表大小2.加快收敛3.限制LSA的扩散4.提高稳定性
=================================================================
OSPF 区域:
1.传输区域(骨干区域) 2.普通区域(非骨干区域)
=================================================================
RouteID 越高越容易成为DR (Designated Router 指定路由器)
RouterID产生?
1. 如果路由器存在回环接口, 则从回环接口中选择最高的IP作为RouterID
2. 如果路由器不存回环, 则从物理接口中选择最高的IP作为RouterID(接口必须处于激活状态)
=================================================================
10.1.1.0/0.0.0.255
10.1.1.0/255.255.255.0
10.1.1.1/255.255.255.255
10.1.1.1/0.0.0.0
Router ospf 1
network 192.168.1.0 0.0.0.255 area 0
进程号不会影响的OSPF的通告学习
=====================================================================
show ip ospf neighbor 查看邻居(NeighborID 即是 RouterID)
show ip ospf interface serial 1 查看RouterID和OSPF的进程号以及相关的网络类型.
show ip protocols
show ip route
=====================================================================
访问控制列表(ACL)
1.控制网络流量 2.实现数据包过滤
ACL有两种类型:
1.标准访问控制列表 1-99,1300-1999 2.扩展访问控制列表 100-199,2000-2699
标准的访问控制列表:仅检测源地址 扩展的访问控制列表:源地址,目标地址,协议,端口号
ACL两种动作:
1.拒绝 2.允许
ACL对于数据包处理:
1. in方向 2. out方向
ACL最重要: ACL条件列表最后会有一个隐藏”拒绝所有”的条件.
=============================================================
实验:
1. 配置ACL拒绝london去访问Denver
采用标准:
access-list 1 deny host 10.3.3.1
access-list 1 permit any
隐藏:access-list 1 deny any
2. 配置ACL拒绝london去Ping通Denver(1)
配置ACL允许london去telnet到Denver(2)
源:   10.3.3.1
目标: 172.16.3.1
协议: ICMP (Internet Control Message protocol)
源端口: None
目标端口: None
动作: Deny
————————————————
源: 10.3.3.1
目标: 172.16.3.1
协议: TCP
源端口: None
目标端口: 23
动作: Permit
————————————————-
access-list 100 deny ICMP host 10.3.3.1 host 172.16.3.1
access-list 100 permit TCP host 10.3.3.1 host 172.16.3.1 eq 23
access-list 100 permit IP any any
标准的访问控制列表应用的位置: 应用在离目标最近的一个接口
扩展的访问控制列表应用的位置: 应用在离源最近的一个接口
show ip interface serial 0 查看接口的acl的配置
show ip access-lists 查看具体的列表条件与匹配信息
====================================================================
冗余的拓扑,会引起 “广播风暴”, “多份帧接收”, “MAC地址表不稳定”.
生成树可以避免冗余所带来的环路问题.解决问题的根本: 将冗余的端口置为阻塞状态.
处于阻塞状态的接口是不会接收/发送用户数据.
=================================================================
BPDU : Bridge Protocol Data Unit 桥协议数据单元
其中包含: BridgeID = Bridge Priority + MAC address
BPDU 每两秒在交换机之间交换一次.周期性的.
=================================================================
以太网链路开销:
10Gbps 2
1Gbps 4
100Mbps 19
10Mbps 100
=================================================================
1.每个网络选举一个根网桥 BridgeID Lowest
2.每个非根网桥选举一个根端口 1) Bandwidth Cost Lowest 2) Recevied BridgeID Lowest
3.每个网段选举一个指定端口 BridgeID Lowest
1) 根端口不参与指定端口的竞争 2) 通常根网桥所有的接口为指定端口
4.非指定端口被置与阻塞状态
=================================================================
生成树端口
阻塞 -> 侦听 -> 学习 -> 转发
20s     15s     15s
=================================================================
show spanning-tree brief 查看生成树状态(3500xl)
(2950/3550 : show spanning-tree)
show spanning-tree interface fastEthernet 0/23 查看接口在生成树中的状态
=================================================================
了解
spanning-tree vlan 1 priority ? 修改交换机的优先级
更改接口的cost开销值
interface fa0/24
spanning-tree vlan 1 cost ??
=================================================================
VLAN 特性
1.A vlan == A broadcast domain == A logic subnet
2.不同的VLAN之间是不能直接的通信的.
VLAN的特点:
1.分段性: 广播域划分
2.灵活性: VLAN可以跨越多台交换机
3.安全性: 不同的VLAN的通信
VLAN的实现方法:
1.基于端口的实现, 静态VLAN 2.基于MAC地址实现, 动态VLAN
TRUNK (干道): 使用了特殊的封装机制去传输多个VLAN的数据.
=================================================================
创建VLAN
vlan database   进入VLAN的数据库配置模式
vlan 10 name cisco 创建一个名叫CISCO的10号VLAN
vlan 20    创建系统自命名的20号VLAN
apply    应用相关的配置
exit    应用并退出VLAN的数据库配置模式
注意: 默认情况下,所有的端口从属于vlan 1(管理VLAN或系统默认VLAN),同时VLAN1是不可以被删除的.
将端口加入到指定的VLAN
interface fastethernet 0/1 进入到快速以太网0/1接口
switchport access vlan 10 将此端口加入到VLAN 10中.
end     退出端口配置械
=================================================================
注意:
1900仅支持ISL干道协议 2950仅支持802.1Q的干道协议 3550支持802.1Q和ISL的干道协议在2950创建一个802.1Q的干道
interface fastethernet 0/1 进入fa0/1接口
switchport mode trunk   更改接口模式为trunk工作模式
在3550创建一个802.1Q的干道
interface fastehternet 0/1 进入fa0/1接口
switchport trunk encapsulation dot1q 需要选择是何种干道 [dot1q|isl]
switchport mode trunk   更改接口模式为trunk工作模式
show interface trunk   查看当前交换机的TRUNK配置
show interfaces fastethernet 0/1 switchport
=================================================================
VTP Vlan Trunk Protocol
VTP 是一个消息系统.能够确保网络上所有的在相同的管理域下面的交换机的VLAN
配置一致.
VTP的消息通告,仅能够在TRUNK上传输.
VTP有三种模式:
1.Server模式 <主> 2.Client模式 <次> 3.TransParent模式 <透明>
VTP是采用多播方式去进行通告,VTP会每隔5分钟通告一次,即使这里没有任何的变化.VTP的交换机会同步最后一次的配置.
=================================================================
配置VTP
vlan database 进入vlan配置模式
vtp domain <string> 配置VTP的域名
vtp password <string> 配置VTP的密码
vtp server 配置此交换机为server模式 [server|client |transparent]
vtp pruning 启用修剪
exit
=================================================================
show vtp status 查看VTP的状态
=================================================================
广域网:
用于连接远程站点.
广域网的类型与封装协议:
1.专线: PPP, HDLC, SLIP
2.电路交换: PPP, HDLC, SLIP
3.包交换: X.25, Frame-Relay, ATM
=================================================================
HDLC:
1.cisco hdlc : 可以支持多协议的环境, 是通过增加”属性”字段实现的.
2.standard hdlc: 仅支持单协议的环境
CISCO的路由器,在serial接口上默认采用cisco HDLC进行封装
在实际应用中, cisco hdlc不兼容standard hdlc.
=================================================================
PPP:
通过NCP能够对多个网络层协议支持 通过LCP可以实现”身份验证”, “压缩”, “错误检测”, “多链路”.
PPP的身份验证方法:
1.PAP: 两次握手, 密码采用明文传输
2.CHAP: 挑战式三次握手, 密码采用HASH算法进行传输, 比PAP更强壮
=================================================================
在接口上启用HDLC:
interface serial 0
encapsulation HDLC
=================================================================
PPP的配置
hostname ABC    配置本地用户名
username 123 password cisco 配置用户名密码数据库, 用于验证对方
interface serial 0
encapsulation PPP   在接口上启用PPP
ppp authentication CHAP   选择采用CHAP进行身份验证 [chap | pap]
debug ppp authentication   调试PPP的身份验证.
=================================================================
PPP 的自主密码配置
interface serial 0
encapsulation PPP   在接口上启用PPP
ppp chap hostname abc   以CHAP方式发送本地用户名
ppp chap password cisco   以CHAP方式发送本地密码
=================================================================
FRAME-RELAY
1.面向连接一种服务.2.连接基于虚链路
PVC :永久虚链路
DLCI: 用于标识PVC的. 仅在本地有效.
LMI: 本地管理接口.
BECN: 后向显式拥塞通告
FECN: 前向显式拥塞通告
=================================================================
FRAME-RELAY 拓扑(pvc)
1. 全网状2. 半网状3. 星型(hub and spoke)
FRAME-RELAY LMI 信令
1. CISCO    2. ANSI       3. Q993A
FRAME-RELAY 是非广播多路访问型的网络, 不支持广播
由FRAME-RELAY不支持广播,会引起路由不可通告. 解决方法: 复制多个帧进行通告.
FRAME-RELAY还会引起,路由不可达问题,即水平分隔规则.
解决水平分隔,可以使用子接口方式.
FRAME-RELAY 地址映射(反向ARP)
=================================================================
frame-relay switching
!
interface Serial0
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 110 interface Serial1 120
!
interface Serial1
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 120 interface Serial0 110
!
show frame-relay lmi
show frame-relay pvc
show frame-relay map
=================================================================
基本的FRAME-RELAY配置
interface s 1
encapsulation frame-relay
ip add 10.1.1.1 255.255.255.0
=================================================================
采用点对点子接口的配置
interface s 1
no ip add
encapsulation frame-relay
no shut
interface s 1.??? point-to-point 启用一个点对点的子接口. ???为接口号.
ip add 10.1.1.1 255.255.255.0 为子接口配置ip
frame-relay interface-dlci ??? 为此子接口分配具体的PVC. ???为PVC号.
=================================================================
采用多点子接口的配置
interface Serial1
no ip address
encapsulation frame-relay
!
interface Serial1.1 multipoint
ip address 10.1.1.1 255.255.255.0
frame-relay map ip 10.1.1.2 110 broadcast 进行手工的静态映射
=================================================================
私有IP地址:
A: 10.0.0.0/8
B: 172.16.0.0/16 — 172.31.0.0/16
C: 192.168.0.0/24 — 192.168.255.0/24
采用私有IP地址的主机,无法直接的访问公共网络(Internet)
私有IP是不会出现的公共网络路由器的路由表中.
=================================================================